PaperCut Hive - Some users are intermittently unable to release print jobs or experience intermittent loading in the Hive admin portal

Incident Report for PaperCut Software

Resolved

This incident has now been fully resolved. We have confirmed that print jobs are releasing successfully.

We know this may have been disruptive and appreciate your patience while we worked through it. We’ll continue to monitor closely and will complete a full review of the incident.

If you experience other issues please report this via https://www.papercut.com/support/.
Posted Apr 13, 2026 - 11:52 UTC

Monitoring

The issue is now resolved and the teams will continue to monitor the cloud services.
Posted Apr 13, 2026 - 09:51 UTC

Investigating

We're currently investigating an intermittent issue affecting PaperCut Hive's print release for the EU hosting region only.

Users may experience intermittent slow loading of pages within the Hive admin portal.


We’re actively working to resolve the issues and will provide updates as they become available.
Posted Apr 13, 2026 - 09:04 UTC
This incident affected: PaperCut Hive & Pocket (EU hosting region - PaperCut Hive & Pocket).