PaperCut Hive & Pocket Cloud Pull Delivery degraded performance - UK hosting region

Incident Report for PaperCut Software

Resolved

Our engineering team has confirmed that Cloud Pull Delivery is now operational and any issues should now be mitigated. Monitoring will continue but we can confirm that functionality has been restored.
Posted Jan 12, 2026 - 17:56 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jan 12, 2026 - 15:57 UTC

Update

We are continuing to investigate this issue.
Posted Jan 12, 2026 - 13:10 UTC

Investigating

We are currently investigating reports of Cloud Pull Delivery Failures within the UK hosting region.

Users that rely on Cloud Pull Delivery as their only method for print jobs may experience failures.
Posted Jan 12, 2026 - 12:31 UTC
This incident affected: PaperCut Hive & Pocket (UK hosting region - PaperCut Hive & Pocket).