PaperCut Pocket/Hive - some users intermittently unable to release print jobs.

Incident Report for PaperCut Software

Monitoring

A fix has been implemented, and the ability to release print jobs is now restored.

We are continuing to monitor this. If you're still experiencing problems please report them via https://www.papercut.com/support/
Posted Jun 10, 2026 - 19:37 UTC

Identified

We have identified the cause of the issue and our product development teams are currently implementing a fix.

While core services have recovered, some affected customers may still experience intermittent print job release issues.
Posted Jun 10, 2026 - 17:28 UTC

Update

We are continuing to investigate this issue.
Posted Jun 10, 2026 - 14:48 UTC

Investigating

PaperCut Hive/Pocket - some users intermittently unable to release print jobs.

We're currently investigating reports of some users experiencing issues releasing print jobs in the UK region.

We are not currently aware of impact to other regions.

We are working with our cloud service provider to investigate and we will provide updates here as they become available.
Posted Jun 10, 2026 - 14:46 UTC
This incident affects: PaperCut Hive & Pocket (UK hosting region - PaperCut Hive & Pocket).