The fix implemented earlier today has proven to mitigate the issue based on the metrics of further monitoring. Print release is now functioning as expected.
From analysis, the impact was to a small subset of organizations across multiple regions, affecting 0.62% of printers.
Posted Dec 01, 2025 - 19:36 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 01, 2025 - 17:04 UTC
Update
We are continuing to investigate this issue.
Posted Dec 01, 2025 - 16:05 UTC
Investigating
Reports of intermittent jobs that fail to release with an error of "jobrouter.assignprocessor.noEdgenodeCanPrintTheJob".
Our team is investigating and we will provide further updates.
Posted Dec 01, 2025 - 15:07 UTC
This incident affected: PaperCut Hive & Pocket (US hosting region - PaperCut Hive & Pocket, AU hosting region - PaperCut Hive & Pocket, UK hosting region - PaperCut Hive & Pocket, EU hosting region - PaperCut Hive & Pocket, CA hosting region - PaperCut Hive & Pocket).